New ongoing "Development" version has been created

User avatar
m1dyp
Posts: 452
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.
Contact:

Re: New ongoing "Development" version has been created

Post by m1dyp » Sun Dec 20, 2020 9:24 am

VK3KYY wrote:
Sun Dec 20, 2020 3:59 am
After a long hiatus I have released another Development / Beta version.

See
https://github.com/rogerclarkmelbourne/ ... 0.12.20.01

Thanks to Daniel F1RMB for 99% of the work on this release, because I have been too busy with my paid / day job to have much time to write any code for the project.


The bulk of the changes are bug fixes, with only 1 very small new feature to help with satellite operation.

Please note.
This version needs completely new voice prompts


https://github.com/LibreDMR/voice-promp ... 0.12.20.01

Because we ran out of space to store the prompts and had to removed 18 unused / placeholder prompts in order to add one or two new prompts which were needed.
thank you very very much
73 de Ken :D

User avatar
SQ7PTE
Posts: 129
Joined: Sat Nov 16, 2019 4:23 am
Location: KO00to
Contact:

Re: New ongoing "Development" version has been created

Post by SQ7PTE » Sun Dec 20, 2020 9:47 am

Is the power in the HotSpot mode permanently (rigidly) set to 1W?
Piotr SQ7PTE :roll:

User avatar
F1RMB
Posts: 934
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: New ongoing "Development" version has been created

Post by F1RMB » Sun Dec 20, 2020 9:50 am

Hi Piotr,
SQ7PTE wrote:
Sun Dec 20, 2020 9:47 am
Is the power in the HotSpot mode permanently (rigidly) set to 1W?
I think you need to read the manual's Hotspot section https://github.com/rogerclarkmelbourne/ ... tspot-mode, or search the forum about MMDVMHost's power setting, like this one viewtopic.php?f=9&t=933&hilit=mmdvmhost+power#p8484

This has been answered multiple times.


Cheers.
---
Daniel
73 de Daniel.

User avatar
SQ7PTE
Posts: 129
Joined: Sat Nov 16, 2019 4:23 am
Location: KO00to
Contact:

Re: New ongoing "Development" version has been created

Post by SQ7PTE » Sun Dec 20, 2020 10:04 am

Hello Daniel.
So far, HotSpot worked with the full power of 5 ++ (of course in the version from 03/05/2020) because, as I have already mentioned in another topic, after this version, each new version caused the error I was describing. Now, after uploading the latest Firmware, the text 1W appeared on the screen - I can't change it, that's why I asked.
Piotr SQ7PTE :roll:

User avatar
F1RMB
Posts: 934
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: New ongoing "Development" version has been created

Post by F1RMB » Sun Dec 20, 2020 10:13 am

Hi Piotr,
SQ7PTE wrote:
Sun Dec 20, 2020 10:04 am
Hello Daniel.
So far, HotSpot worked with the full power of 5 ++ (of course in the version from 03/05/2020) because, as I have already mentioned in another topic, after this version, each new version caused the error I was describing. Now, after uploading the latest Firmware, the text 1W appeared on the screen - I can't change it, that's why I asked.

As it was stated long ago, if your MMDVMHost config has RFLevel set to 100, the current power set on the GD will be used, otherwise, refer to the power/value table.
About the error you're mentioning, if it's about the USB reset because of the power fed back to the RPi USB port, it has also been stated that we can't fix your installation by software, at it's purely a RF problem, induced by cabling, etc.
73 de Daniel.

User avatar
SQ7PTE
Posts: 129
Joined: Sat Nov 16, 2019 4:23 am
Location: KO00to
Contact:

Re: New ongoing "Development" version has been created

Post by SQ7PTE » Sun Dec 20, 2020 10:17 am

I understand, Daniel.
But why does the bug appear after the version of 5/3/200? This is puzzling. I understand, Daniel.
By uploading the version on 03/05/2020, I do not change the power supply.
Not only that, HotSpot is set to 5 ++ and works great, great.
Piotr SQ7PTE :roll:

OM8AMV
Posts: 51
Joined: Thu Jun 25, 2020 7:26 pm

Re: New ongoing "Development" version has been created

Post by OM8AMV » Sun Dec 20, 2020 10:26 am

in new version after turn on, backlight not shine when is bootscreen visible.
OM8AMV
Radioddity GD-77

User avatar
F1RMB
Posts: 934
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: New ongoing "Development" version has been created

Post by F1RMB » Sun Dec 20, 2020 10:30 am

Hi,
OM8AMV wrote:
Sun Dec 20, 2020 10:26 am
in new version after turn on, backlight not shine when is bootscreen visible.
Ah, yes, good finding.


Cheers.
---
Daniel
73 de Daniel.

W1CY
Posts: 32
Joined: Sun Jan 12, 2020 6:57 pm

Re: New ongoing "Development" version has been created

Post by W1CY » Mon Dec 21, 2020 3:52 am

OM8AMV wrote:
Sun Dec 20, 2020 10:26 am
in new version after turn on, backlight not shine when is bootscreen visible.
I second that, the display only comes up after the initial screen.

VK3KYY
Posts: 3331
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: New ongoing "Development" version has been created

Post by VK3KYY » Mon Dec 21, 2020 4:45 am

I'll release a update to fix this today.

(Daniel already sent me a fix)

Post Reply