SM-land codeplug (Sweden)

Post your OpenGD77 codeplugs here
SA0BUX
Posts: 642
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: SM-land codeplug (Sweden)

Post by SA0BUX » Wed Apr 03, 2024 4:16 pm

SA0ASM wrote:
Wed Apr 03, 2024 4:08 pm
Yes, this is a known issue in the OpenGD77 CPS. The label texts are converted to a chinese character set in the GUI, however importing UTF-8 from CSV works fine as you have witnessed. I have reported this bug here: viewtopic.php?f=11&t=3625&p=28295 Please feel free to chime in to that thread!

73 de SA0ASM
But the serious problem is that all frequency data is corrupted when you import UTF-8 so the programmed channels are unuseable

OZ1MAX
Posts: 37
Joined: Sat Nov 16, 2019 11:43 pm

Re: SM-land codeplug (Sweden)

Post by OZ1MAX » Thu Apr 04, 2024 6:24 am

hej ASM

It could be nice to try it with OZ/SM and LA also, traveling accross and between would be easy to have a comlete code plug .. ;)

Thanks in advange
De OZ1MAX Hardy

SA0BUX
Posts: 642
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: SM-land codeplug (Sweden)

Post by SA0BUX » Thu Apr 04, 2024 7:37 am

OZ1MAX wrote:
Thu Apr 04, 2024 6:24 am
hej ASM

It could be nice to try it with OZ/SM and LA also, traveling accross and between would be easy to have a comlete code plug .. ;)

Thanks in advange
De OZ1MAX Hardy
We have two amateurs that make a codeplug for Anytone 578/878 that are working on a Opengd77 version too with the same channel data as in the Anytone one.
That codeplug includes Norwegian and Danish repeaters too.
It will be available shortly.

OZ1FTG
Posts: 42
Joined: Fri Mar 29, 2024 3:52 pm

Re: SM-land codeplug (Sweden)

Post by OZ1FTG » Thu Apr 04, 2024 1:35 pm

That would be very neat :) - With a "Scandinavian codeplug"

I just got my first GD77 (MV-UV380) clone
viewtopic.php?f=8&t=3949

And have 2 DM-1701's under way , they were on offer on Ali for $50/pcs

SA0ASM
Posts: 27
Joined: Thu Dec 21, 2023 5:00 pm
Location: JO89xi, Bromma, Sweden

Re: SM-land codeplug (Sweden)

Post by SA0ASM » Fri Apr 05, 2024 2:51 pm

@SA0BUX I don't think you understand, the "unusable" nature of the CPS is a bug in the CPS software UI, not of the CVS import. You can import correct labels and even edit the results in the CPS, but the CPS will always show the UTF-8 names garbled. Everything works fine in the radio though, once the data is programmed.

I have tried to get the developers to understand how to fix the issue in the CPS, but they have other things to fix which they prioritize over UTF-8 support.

73 de SA0ASM

SA0BUX
Posts: 642
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: SM-land codeplug (Sweden)

Post by SA0BUX » Fri Apr 05, 2024 4:42 pm

SA0ASM wrote:
Fri Apr 05, 2024 2:51 pm
@SA0BUX I don't think you understand, the "unusable" nature of the CPS is a bug in the CPS software UI, not of the CVS import. You can import correct labels and even edit the results in the CPS, but the CPS will always show the UTF-8 names garbled. Everything works fine in the radio though, once the data is programmed.

I have tried to get the developers to understand how to fix the issue in the CPS, but they have other things to fix which they prioritize over UTF-8 support.

73 de SA0ASM
Nope, or do you say that if I enter UTF-8 into channel name in the cps (not via csv import) it will automatically corrupt the frequencies?

Importing the UTF-8 coded csv files from rptconvert and getting crazy frequencies but åäö in channel name is not a useful "feature".

Maybe you should ask what character encodings is supported in the cps and the radio first ?

SA0BUX
Posts: 642
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: SM-land codeplug (Sweden)

Post by SA0BUX » Fri Apr 05, 2024 5:22 pm

The python script works fine when I convert everything to 7-bit ascii before the csv files are imported into the cps.
But getting 127.000 MHz RX and 380.0848 MHz TX for a repeater that is on 2 meter or 70 cm in the input file is not usable.

SA0ASM
Posts: 27
Joined: Thu Dec 21, 2023 5:00 pm
Location: JO89xi, Bromma, Sweden

Re: SM-land codeplug (Sweden)

Post by SA0ASM » Fri Apr 05, 2024 6:22 pm

You shouldn't need to convert anything to ASCII, the firmware supports an extended latin characterset and the CSV files should contain UTF-8 encoded data for this to work. I don't know what problems you are having with the split frequency, the following CSV data imports fine for me:

Code: Select all

Channel Number,Channel Name,Channel Type,Rx Frequency,Tx Frequency,Bandwidth (kHz),Colour Code,Timeslot,Contact,TG List,DMR ID,TS1_TA_Tx,TS2_TA_Tx ID,RX Tone,TX Tone,Squelch,Power,Rx Only,Zone Skip,All Skip,TOT,VOX,No Beep,No Eco,APRS,Latitude,Longitude
1,Test Channel,Analogue,	127.00000,	380.08480,12.5,,,,,,,,None,None,Disabled,Master,No,No,No,0,Off,No,No,None,0,0
Are you QRV on TG 240? Maybe we could have a QSO about this instead?

73 de SA0ASM

SA0ASM
Posts: 27
Joined: Thu Dec 21, 2023 5:00 pm
Location: JO89xi, Bromma, Sweden

Re: SM-land codeplug (Sweden)

Post by SA0ASM » Fri Apr 05, 2024 6:24 pm

Thinking a bit more about your symptoms, it seems like you have a problem with the field delimeters in your CVS files. Are you sure you aren't using commas to separate fields and also as decimal point in your frequencies?

73 de SA0ASM

SA0BUX
Posts: 642
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: SM-land codeplug (Sweden)

Post by SA0BUX » Sat Apr 06, 2024 1:46 pm

SA0ASM wrote:
Fri Apr 05, 2024 6:24 pm
Thinking a bit more about your symptoms, it seems like you have a problem with the field delimeters in your CVS files. Are you sure you aren't using commas to separate fields and also as decimal point in your frequencies?

73 de SA0ASM
No, I tried to recap it now as I couldn't reproduce it on another Windows 10 PC.
So today I took the same Windows 11 laptop that I used that day, I see in my screenshoots that I had the 2024.03.30.01 CPS.
It's English windows but the regional format is set to "English (Sweden)".

I even tried to set the regional format to "English (United States)" now and imported the files, frequncies where OK this time.
But I noticed that the Lat/Long for SM3VAC Nyland was 157/238 now (should be 63,01 / 17,74 ) so it made some difference.

It's bad that I don't have those CSV files that I used 2024-03-30 , maybe they had something in them that affected the import.

Post Reply