10W UV390 PLUS SCREEN BRIGHTNESS

User avatar
i5ekx
Posts: 44
Joined: Fri Dec 09, 2022 3:14 pm
Location: JN53DM
Contact:

Re: 10W UV390 PLUS SCREEN BRIGHTNESS

Post by i5ekx » Wed Jul 10, 2024 10:58 am

......I forgot, you can read inside, but in the sun it is difficult to see the display well. In practice, with the original and modified FW the 5W version is always bright, the 10W version with the original FW is bright, with the modified FW it dims a lot making reading difficult in broad daylight.

User avatar
i5ekx
Posts: 44
Joined: Fri Dec 09, 2022 3:14 pm
Location: JN53DM
Contact:

Re: 10W UV390 PLUS SCREEN BRIGHTNESS

Post by i5ekx » Wed Jul 10, 2024 11:22 am

SA0BUX wrote:
Wed Jul 10, 2024 10:41 am
i5ekx wrote:
Wed Jul 10, 2024 10:29 am
I received the UV-MD390 Plus 10W, in fact the display next to the 5W version is significantly less bright, but still readable. I don't understand if this has happened since the latest version of the FW or has always been present.
I hope that the programming team can solve the problem because it is quite unpleasant, I thank them for their great work which has made these radios truly performing!
I guess they need to dissect some Plus 10W radios and try to understand how the brightness is controlled and how it differs from the other models.
Yes, but does it happen from now with the latest version or even earlier? I received the 10W version this morning and therefore it is the first time I have installed OpenGD77 on it.

SA0BUX
Posts: 636
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: 10W UV390 PLUS SCREEN BRIGHTNESS

Post by SA0BUX » Wed Jul 10, 2024 11:29 am

i5ekx wrote:
Wed Jul 10, 2024 11:22 am
SA0BUX wrote:
Wed Jul 10, 2024 10:41 am
i5ekx wrote:
Wed Jul 10, 2024 10:29 am
I received the UV-MD390 Plus 10W, in fact the display next to the 5W version is significantly less bright, but still readable. I don't understand if this has happened since the latest version of the FW or has always been present.
I hope that the programming team can solve the problem because it is quite unpleasant, I thank them for their great work which has made these radios truly performing!
I guess they need to dissect some Plus 10W radios and try to understand how the brightness is controlled and how it differs from the other models.
Yes, but does it happen from now with the latest version or even earlier? I received the 10W version this morning and therefore it is the first time I have installed OpenGD77 on it.
According to what I have read in the forum it has been an issue from the beginning, there was also some other problems due to different GPIO pin mapping compared to the 5W models.

User avatar
i5ekx
Posts: 44
Joined: Fri Dec 09, 2022 3:14 pm
Location: JN53DM
Contact:

Re: 10W UV390 PLUS SCREEN BRIGHTNESS

Post by i5ekx » Wed Jul 10, 2024 1:12 pm

Ok, thanks, let's hope it can be resolved then, I'm convinced that the development team will find a way ;)

User avatar
i5ekx
Posts: 44
Joined: Fri Dec 09, 2022 3:14 pm
Location: JN53DM
Contact:

Re: 10W UV390 PLUS SCREEN BRIGHTNESS

Post by i5ekx » Thu Jul 11, 2024 8:08 am

F1RMB wrote:
Thu Jun 06, 2024 2:38 pm
Okay.
But does the white looks white ? On the first picture (replaced too), the background don't really looks to be white.

Well, you're running the latest beta version (20240511), so at 100% the backlight is not using PWM at all, so you can't get anything brighter.
Maybe you can check if running the manufacturer's firmware make it brighter, or whiter (do you need to install a special firmware version on this one, I mean, not the "standard" MD-UV380 one ?).
Maybe the LCD screen configuration is a bit different (like gamma curve, and stuff like this).

BTW, the LCD panel on my RT3S is not as bright as my MD-UV390.
Cheers.
---
Daniel
Hi Daniel, do you think it is possible to work on this problem? If you think it might be useful, I'm available for any tests on my radio.

Post Reply