TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

VK3KYY
Posts: 7572
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by VK3KYY » Fri Feb 16, 2024 9:21 pm

SA0BUX wrote:
Fri Feb 16, 2024 11:21 am
Tried the new 20240215 release on the RT82 but the CTCSS and DCS modulation seems too high so radio can't open any repeaters/radios with subtone.

Reverted back to 20240126 and subtones work again

The RSSI test version 20240209 073001 have same problem with subtone levels.
I just did some testing but have no problems with any repeaters that use CTCSS

I checked the TRx parameters and they seem to be the same as the previous vesion.

I need to confirm whether all the paramaters are being sent to the TRx, becuase there is something strange going on, where some parameters which are sent during initialisation don't seem to be in the TRx chip (AT1846S) when I read them via the debug mode interface

VK3KYY
Posts: 7572
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by VK3KYY » Fri Feb 16, 2024 9:58 pm

Umm

In both this version and the previous version there is some problem with the AT1846S configuation. At the moment I'm not sure what is causing this

VK3KYY
Posts: 7572
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by VK3KYY » Sat Feb 17, 2024 8:20 am

I've tested the CTCSS during Tx but I have no problems

Nevertheless I've reverted the change to the AT1846S register 0x05, and also made some small unrelated changes to the receive audio level

See

https://opengd77.com/downloads/MD2017/F ... 7815ba887b

SA0BUX
Posts: 574
Joined: Tue Jul 05, 2022 8:50 am
Location: JO99ah, Stockholm, Sweden
Contact:

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by SA0BUX » Sat Feb 17, 2024 12:55 pm

VK3KYY wrote:
Sat Feb 17, 2024 8:20 am
I've tested the CTCSS during Tx but I have no problems

Nevertheless I've reverted the change to the AT1846S register 0x05, and also made some small unrelated changes to the receive audio level

See

https://opengd77.com/downloads/MD2017/F ... 7815ba887b
Had to dig more into this as I had the same problem with the newer release and I found that it worked in FMN but not FM.
Then I connected the RT82 to my counter and saw that the frequency differ in FM and FMN by around -3.3 kHz.

With 2024-02-17 & 2024-02-15
VFO 145.000:
144.996722 FM ( -3.278 kHz )
144.999848 FMN ( -0.152 kHz )

VFO 434.000:
433.996670 FM ( -3.33 kHz )
433.999979 FMN ( -0.021 kHz )

With 2024-01-26
VFO 145.000:
144.999839 FM ( -0.161 kHz )
144.999843 FMN ( -0.157 kHz )

VFO 434.000:
433.999766 FM ( -0.234 kHz )
433.999765 FMN ( -0.235 kHz )

I compared with one of my RT3S but I could not see any obvious frequency difference between FM & FMN on that radio

VK3KYY
Posts: 7572
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by VK3KYY » Sat Feb 17, 2024 8:35 pm

Ok

I will check the code.

I remember a frequency correction had to be inserted for one of the radio types, but I can remember the amount.

I think the TRx chip (AT1868S), has a lot of secrets which we don't understand

VK3KYY
Posts: 7572
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by VK3KYY » Sat Feb 17, 2024 10:01 pm

I had a look in the code and a hack was applied to the UV380 code where it always adds 3kHz for Tx

We don't know why this was needed for the UV380, and we use code in the MD2017

I thought this may be something to do with the undocumted register 0x05, as this needs different values for DMR and FM, which seems to disable audio filtering.
But I just did some tests and changing this register doesn't make any difference.

The problem seems to be that 25kHz FM is 3kHz too low

DMR and FMN seem to be on the same frequency, which is the same frequency I observe on my other radios e.g. my GD77 etc

Anyway. At the moment I can't see why 25kHz FM is 3kHz lower than the other frequencies but I agree that its definietly happening

I'll need to compare the settings between Alpha 1 and Alpha 2 because I can see that its only Alpha 2 that has this problem.

YO3IDG
Posts: 23
Joined: Fri Feb 09, 2024 11:01 pm

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by YO3IDG » Thu Feb 22, 2024 10:03 am

Has anyone noticed the battery level dropping in transmit with same rate as the transmit countdown?

The behaviour I get on my radio is the following:
- push PTT to enter transmit
- transmit timer countdown starts on screen
- battery level indicator drops with each second passed
- stop transmit (release PTT)
- watch battery level
- battery level goes back up to pre-transmit level in about 2-3 seconds
- redo steps above to get the same behavior

Maybe my radio has a problem, I have only one of these radios and can't cross check.

bg0dpj
Posts: 13
Joined: Fri Nov 24, 2023 5:47 pm

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by bg0dpj » Sun Feb 25, 2024 3:03 pm

Good evening, BG0DPJ here

Firstly, I would like to thank the team for their hard work. Currently, I am using TYT-760 and 390 with the Open GD77 firmware installed, both of which are very good. Today, just a few hours ago, I attempted to flash TYT-MD2017/Retevis RT-82 Public Alpha 2.0 version

Currently in use, a clicking sound has been detected, accompanied by the signal entering and ending.

Can the speed of the trackball be adjusted? Currently, I feel that the speed is too fast and I am not keeping up with it.

The trackball is too easy to accidentally touch, and sometimes the channel may have changed without knowing it.

Simulated mode cannot open local relay, both 760 and 390 can be opened.

Other issues are waiting to be discovered during future use.


Sorry, I don't know English. These are all software translations. If there are any errors, please forgive me.

bg0dpj
Posts: 13
Joined: Fri Nov 24, 2023 5:47 pm

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by bg0dpj » Mon Feb 26, 2024 4:45 am

Used for several hours after installing the firmware

The circular blue button seems to have no function, while other function keys are working normally. Currently, the most troublesome thing is the tower sound emitted by the speaker. No matter what operation, there is a tower sound in any operation. After adapting to any operation, the trackball feels that the speed can also be received.

VK3KYY
Posts: 7572
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia

Re: TYT MD2017 / Retevis RT-82 Public Alpha 2.0 version

Post by VK3KYY » Mon Feb 26, 2024 7:11 am

bg0dpj wrote:
Mon Feb 26, 2024 4:45 am
Used for several hours after installing the firmware

The circular blue button seems to have no function, while other function keys are working normally. Currently, the most troublesome thing is the tower sound emitted by the speaker. No matter what operation, there is a tower sound in any operation. After adapting to any operation, the trackball feels that the speed can also be received.
Please read the original Alpha post, which explains the buttons

viewtopic.php?f=28&t=3717

Post Reply